バージョン選択

フォーラム

メニュー

オンライン状況

60 人のユーザが現在オンラインです。 (17 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 59
yurtdsuni もっと...

サイト内検索

その他 > バージョンアップ > 2.13.1から2.17へのバージョンアップについて

バージョンアップ

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
waiya
投稿日時: 2020/2/18 17:51
対応状況: −−−
半人前
登録日: 2009/5/29
居住地: 大阪市
投稿: 13
2.13.1から2.17へのバージョンアップについて
ECCUBE2.13.1から2.17へバージョンアップしたいと思い
https://qiita.com/nanasess/items/ff9bbde34f7d44240c06
こちらを参考にさせていただきながら、
作業を進めておりまして、2.17のマージからサーバ環境でのcomposer installまで行ったところで、以下のようなエラーがでてしまいました。

=========
Fatal error(E_ERROR): Uncaught Error: Using $this when not in object context in /*** server path ***/data/Smarty/templates_c/ishoubatake/7d81b1b350ad4d890552e9171a49b78edc91646f_0.file.site_frame.tpl.php:78
Stack trace:
#0 /*** server path ***/data/vendor/smarty/smarty/libs/sysplugins/smarty_template_resource_base.php(123): content_5e4b89fd98c0a3_40116529(Object(Smarty_Internal_Template))
#1 /*** server path ***/data/vendor/smarty/smarty/libs/sysplugins/smarty_template_compiled.php(114): Smarty_Template_Resource_Base->getRenderedTemplateCode(Object(Smarty_Internal_Template))
#2 /*** server path ***/data/vendor/smarty/smarty/libs/sysplugins/smarty_internal_template.php(216): Smarty_Template_Compiled->render(Object(Smarty_Internal_Template))
#3 /*** server path ***/data/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php(232): Smarty_Internal_Template->render(false, 0)
#4 /*** server path ***/data/vendor/smarty/smarty/libs/sysplugins/smarty_int on [/*** server path ***/data/Smarty/templates_c/ishoubatake/7d81b1b350ad4d890552e9171a49b78edc91646f_0.file.site_frame.tpl.php(78)]
=========

もともとカスタムされたテンプレートでしたので、そちらの問題かもしれませんが、ご存知の方おられましたら、ご教示いただきたいです。
何卒よろしくお願いいたします。


■作業内容・環境
[EC-CUBE] 2.13.1 ⇒ 2.17へのアップデート
[PHP] PHP7.3
[データベース] MySQL 5.6
[WEBサーバ] 使用しているWEBサーバ名、バージョン
[ブラウザ] chrome
[カスタマイズの有無] フロント画面のテンプレートは全体的にカスタマイズしています。
waiya
投稿日時: 2020/2/20 12:57
対応状況: 解決済
半人前
登録日: 2009/5/29
居住地: 大阪市
投稿: 13
Re: 2.13.1から2.17へのバージョンアップについて
自己解決しました。

テンプレート内に直接PHPを実行している箇所があり、その部分で以下のような記述がある部分がございました。

<!--{php}-->
$_layout = $this->get_template_vars('arrPageLayout');
....
<!--{/php}-->

で、上記の変数が参照できなくなっていただけでした。
こちらを

<!--{php}-->
$_layout = $_smarty_tpl->tpl_vars['arrPageLayout'];
....
<!--{/php}-->

と書き換えして対応できました。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は60,914名です
総投稿数は95,430件です

投稿数ランキング

1
seasoft
7332
2
AMUAMU
2712
3
nanasess
2038
4
468
2022
5
yuh
1612
6
umebius
1588
7
red
1399
8
h_tanaka
992
9
fukap
907
10
tsuji
863
11
shutta
835
12 ramrun 789
13
tao_s
783
14 karin 656
15 sumida 641
16
homan
633
17 DELIGHT 571
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.