バージョン選択

フォーラム

メニュー

オンライン状況

28 人のユーザが現在オンラインです。 (15 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 28
もっと...

サイト内検索

プラグイン > その他 > 決済プラグインのアップデートについて

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
ksmar
投稿日時: 2021/1/15 17:23
対応状況: −−−
新米
登録日: 2019/5/15
居住地:
投稿: 5
決済プラグインのアップデートについて
▼テンプレート
[EC-CUBE] 4.0.2
[レンタルサーバ] AWS
[OS] Linux ip-172-10-100-49.ap-northeast-1.compute.internal 4.14.106-97.85.amzn2.x86_64 #1 SMP Fri Mar 15 17:07:54 UTC 2019 x86_64
[PHP] 7.2.16
[データベース] MySQL 5.7.12
[WEBサーバ] Apache/2.4.39
[ブラウザ] Chrome
[導入プラグインの有無] GmoPaymentGateway4

[現象]
GmoPaymentGateway4のアップデートを実施
1.0.3→1.08

アップデートしようとすると下記エラーが発生。
原因を教えていただきたいです。


**************** Disable ****************
**************** Upgrade ****************
<warning>Deprecation warning: require.ec-cube/GmoPaymentGateway4 is invalid, it should not contain uppercase characters. Please use ec-cube/gmopaymentgateway4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/MGSocialButton is invalid, it should not contain uppercase characters. Please use ec-cube/mgsocialbutton instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/MailMagazine4 is invalid, it should not contain uppercase characters. Please use ec-cube/mailmagazine4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require.ec-cube/tbsFeaturePage is invalid, it should not contain uppercase characters. Please use ec-cube/tbsfeaturepage instead. Make sure you fix this as Composer 2.0 will error.</warning>
<warning>Deprecation warning: require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead. Make sure you fix this as Composer 2.0 will error.</warning>
[18.8MiB/1.11s] <warning>Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade. See https://getcomposer.org/2</warning>
[194.7MiB/4.28s] ./composer.json has been updated
[195.1MiB/4.33s] <warning>Deprecation warning: require.ec-cube/GmoPaymentGateway4 is invalid, it should not contain uppercase characters. Please use ec-cube/gmopaymentgateway4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[195.1MiB/4.33s] <warning>Deprecation warning: require.ec-cube/MGSocialButton is invalid, it should not contain uppercase characters. Please use ec-cube/mgsocialbutton instead. Make sure you fix this as Composer 2.0 will error.</warning>
[195.1MiB/4.33s] <warning>Deprecation warning: require.ec-cube/MailMagazine4 is invalid, it should not contain uppercase characters. Please use ec-cube/mailmagazine4 instead. Make sure you fix this as Composer 2.0 will error.</warning>
[195.1MiB/4.33s] <warning>Deprecation warning: require.ec-cube/tbsFeaturePage is invalid, it should not contain uppercase characters. Please use ec-cube/tbsfeaturepage instead. Make sure you fix this as Composer 2.0 will error.</warning>
[195.1MiB/4.33s] <warning>Deprecation warning: require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead. Make sure you fix this as Composer 2.0 will error.</warning>
[199.1MiB/4.64s] <warning>Dependency "ec-cube/plugin-installer" is also a root requirement, but is not explicitly whitelisted. Ignoring.</warning>
[198.9MiB/4.64s] Loading composer repositories with package information
[200.1MiB/5.72s] <warning>Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade. See https://getcomposer.org/2</warning>
[200.1MiB/5.72s] Updating dependencies (including require-dev)
[734.6MiB/35.89s] Package operations: 0 installs, 1 update, 0 removals
[734.7MiB/35.89s] - Updating ec-cube/gmopaymentgateway4 (1.0.3 => 1.0.8):
In Filesystem.php line 211:

Could not delete app/Plugin/GmoPaymentGateway4/Form/Extension/Admin/OrderEx
tention.php: The "Eccube\Service\Composer\ComposerApiService" service is pr
ivate, getting it from the container is deprecated since Symfony 3.2 and wi
ll fail in 4.0. You should either make the service public, or stop using th
e container directly and use dependency injection instead.


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...

joolensato
投稿日時: 2021/1/16 12:44
対応状況: −−−
常連
登録日: 2019/3/20
居住地:
投稿: 51
Re: 決済プラグインのアップデートについて
Composerが古い
というエラー出ています。
単純にアップデートすればいいのですが、他にも影響が出ますので
開発元のGmoに問い合わせた方がいいかもしれません。
ksmar
投稿日時: 2021/1/19 18:16
対応状況: −−−
新米
登録日: 2019/5/15
居住地:
投稿: 5
Re: 決済プラグインのアップデートについて
joolensatoさん

ありがとうございます。
なるほど。GMO側に問い合わせてみます。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBEペイメント

公式ストアEC-CUBE4系デザインテンプレート続々リリース中

統計情報

総メンバー数は70,501名です
総投稿数は100,697件です

投稿数ランキング

1
seasoft
7333
2
468
2922
3
AMUAMU
2712
4
nanasess
2127
5
umebius
1931
6
yuh
1612
7
red
1437
8
h_tanaka
1076
9
tsuji
926
10
fukap
907
11
shutta
835
12
tao_s
793
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.