バージョン選択

フォーラム

メニュー

オンライン状況

26 人のユーザが現在オンラインです。 (14 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 25
levis501 もっと...

サイト内検索

質問 > その他 > 「簡単ブログ Pro for EC-CUBE4 」のプラグインがインストールできない

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
you01haya
投稿日時: 2023/1/3 15:00
対応状況: 確認中
新米
登録日: 2022/10/12
居住地:
投稿: 5
「簡単ブログ Pro for EC-CUBE4 」のプラグインがインストールできない
[EC-CUBE] 4.1.1
[レンタルサーバ] Xserver
[OS] Linux
[PHP] 7.3.33
[データベース] MySQL 10.5.13
[WEBサーバ] Apache
[ブラウザ] Chrome
[導入プラグインの有無] 有 : ペイパルチェックアウト決済プラグイン(4.1系)
[現象]
「簡単ブログPro for EC-CUBE4」を購入後、インストールを試みたところ、管理画面のプラグイン一覧に、プラグイン名/バージョン/コードは表示されるのですが、ステータスやアップデート、有効化/無効化および設定ボタンが表示されない状態です。

下記コマンドラインでのインストールを試したところ、なんの反応もなくフリーズしてしまいました。
 bin/console eccube:composer:require ec-cube/cmblogpro

また管理画面からのインストールでは、「インストール完了しました」のメッセージは表示されるのですが、下記のとおりwarningも表示されました。
ec-cube/plugin-installerに関する警告が出ていることから、バージョンに不整合があるかと思っているのですが、アドバイスいただけないでしょうか。よろしくお願いします。

[11.8MiB/0.99s] Using version ^1.2 for ec-cube/cmblogpro
[11.8MiB/0.99s] ./composer.json has been updated
[14.1MiB/1.02s] Running composer update ec-cube/cmblogpro --with-dependencies
[16.3MiB/1.03s] Loading composer repositories with package information
[17.7MiB/1.89s] <warning>Dependency ec-cube/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.</warning>
[18.0MiB/1.90s] Updating dependencies
[18.7MiB/1.92s] Nothing to modify in lock file
[19.5MiB/1.94s] Installing dependencies from lock file
[20.1MiB/1.94s] Nothing to install, update or remove
[20.9MiB/1.95s] <warning>Package doctrine/doctrine-cache-bundle is abandoned, you should avoid using it. No replacement was suggested.</warning>
[20.9MiB/1.95s] <warning>Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.</warning>
[20.9MiB/1.95s] <warning>Package easycorp/easy-log-handler is abandoned, you should avoid using it. No replacement was suggested.</warning>
[20.9MiB/1.95s] <warning>Package setasign/fpdi-tcpdf is abandoned, you should avoid using it. No replacement was suggested.</warning>
[20.9MiB/1.95s] <warning>Package swiftmailer/swiftmailer is abandoned, you should avoid using it. Use symfony/mailer instead.</warning>
[20.9MiB/1.95s] <warning>Package symfony/inflector is abandoned, you should avoid using it. Use EnglishInflector from the String component instead.</warning>
[20.9MiB/1.95s] <warning>Package symfony/swiftmailer-bundle is abandoned, you should avoid using it. Use symfony/mailer instead.</warning>
[20.9MiB/1.95s] <warning>Package twig/extensions is abandoned, you should avoid using it. No replacement was suggested.</warning>
[20.9MiB/1.95s] <warning>Package fzaninotto/faker is abandoned, you should avoid using it. No replacement was suggested.</warning>
[20.9MiB/1.95s] Generating optimized autoload files
[38.0MiB/4.11s] <warning>Class Eccube\Entity\Customer located in ./app/proxy/entity/src/Eccube/Entity/Customer.php does not comply with psr-4 autoloading standard. Skipping.</warning>
[38.0MiB/4.12s] <warning>Class Eccube\Entity\Order located in ./app/proxy/entity/src/Eccube/Entity/Order.php does not comply with psr-4 autoloading standard. Skipping.</warning>
[38.0MiB/4.12s] <warning>Class Eccube\Entity\ProductClass located in ./app/proxy/entity/src/Eccube/Entity/ProductClass.php does not comply with psr-4 autoloading standard. Skipping.</warning>
[26.1MiB/4.69s] 103 packages you are using are looking for funding.
[26.1MiB/4.69s] Use the `composer fund` command to find out more!
[26.1MiB/4.69s] Memory usage: 26.08MiB (peak: 60.05MiB), time: 4.69s
mcontact
投稿日時: 2023/1/5 12:15
対応状況: −−−
仙人
登録日: 2022/1/22
居住地:
投稿: 364
Re: 「簡単ブログ Pro for EC-CUBE4 」のプラグインがインストールできない
EC-CUBEのログは確認できますか?
どのようなエラーが出ますでしょうか?
var/log/prod/site-yyyy-mm-dd.log に「システムエラーが発生しました」といった行がありましたらご提示ください。


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

you01haya
投稿日時: 2023/1/5 18:32
対応状況: −−−
新米
登録日: 2022/10/12
居住地:
投稿: 5
Re: 「簡単ブログ Pro for EC-CUBE4 」のプラグインがインストールできない
mcontact様

ご連絡いただき、ありがとうございます。

アドバイスいただいた、var/log/prod/site-yyyy-mm-dd.logを確認しましたが、「システムエラーが発生しました」といったメッセージはありませんでした。

ただ、下記のように、app/Pluginにプラグインのcomppser.jsonがないとのエラーメッセージが出ていました。

今回インストールしようとしているプラグインとEC-CUBE4.1.1のえeccue/plugin-installerの依存関係に不整合があるのではないかと推測しているのですが、いかがでしょうか。

ひきつづき、アドバイスいただけると大変ありがたいです。

[2023-01-02 13:05:06] console.CRITICAL [N/A] [8d72030] [N/A] [Symfony\Component\Console\EventListener\ErrorListener:onConsoleError:48] - Error thrown while running command "eccube:composer:remove 'ec-cube/cmblogpro'". Message: "/home/XXXXXXXXX/○○○○○○.com/app/homonshika-shinryo/app/Plugin/cmblogpro/composer.json not found." {"exception":"[object] (Eccube\\Exception\\PluginException(code: 0): /home/XXXXXXXXX/○○○○○○.com/app/○○○○○○/app/Plugin/cmblogpro/composer.json not found. at /home/XXXXXXXXX/○○○○○○.com/app/homonshika-shinryo/src/Eccube/Service/PluginContext.php:74)","command":"eccube:composer:remove 'ec-cube/cmblogpro'","message":"/home/XXXXXXXXX/○○○○○○.com/app/homonshika-shinryo/app/Plugin/cmblogpro/composer.json not found."} [, , , , ]
mcontact
投稿日時: 2023/1/5 19:12
対応状況: −−−
仙人
登録日: 2022/1/22
居住地:
投稿: 364
Re: 「簡単ブログ Pro for EC-CUBE4 」のプラグインがインストールできない
プラグイン関連のエラーは、サーバーの性能不足に起因する場合があります。
参考ですが、共有レンタルサーバーではなく、VPSやクラウド(経験上6コア/メモリ8GB 以上)であれば比較的安定してます。

https://qiita.com/nanasess/items/791c9ec98f69ada93ea0

※すいませんがEC-CUBE4.1系なので、関係ないかもしれませんがサーバスペックが不足している可能性があります。


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

mcontact
投稿日時: 2023/1/5 23:01
対応状況: −−−
仙人
登録日: 2022/1/22
居住地:
投稿: 364
Re: 「簡単ブログ Pro for EC-CUBE4 」のプラグインがインストールできない
> 「簡単ブログPro for EC-CUBE4」を購入後、インストールを試みたところ、管理画面のプラグイン一覧に、プラグイン名/バージョン/コードは表示されるのですが、ステータスやアップデート、有効化/無効化および設定ボタンが表示されない状態です。

インストールが正常に行われていない可能性があります。

引用:

[11.8MiB/0.99s] Using version ^1.2 for ec-cube/cmblogpro
[11.8MiB/0.99s] ./composer.json has been updated
[14.1MiB/1.02s] Running composer update ec-cube/cmblogpro --with-dependencies
[16.3MiB/1.03s] Loading composer repositories with package information
[17.7MiB/1.89s] <warning>Dependency ec-cube/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.</warning>
[18.0MiB/1.90s] Updating dependencies
[18.7MiB/1.92s] Nothing to modify in lock file
[19.5MiB/1.94s] Installing dependencies from lock file
[20.1MiB/1.94s] Nothing to install, update or remove
[20.9MiB/1.95s] <warning>Package doctrine/doctrine-cache-bundle is abandoned, you should avoid using it. No replacement was suggested.</warning>
[20.9MiB/1.95s] <warning>Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.</warning>
[20.9MiB/1.95s] <warning>Package easycorp/easy-log-handler is abandoned, you should avoid using it. No replacement was suggested.</warning>
[20.9MiB/1.95s] <warning>Package setasign/fpdi-tcpdf is abandoned, you should avoid using it. No replacement was suggested.</warning>
[20.9MiB/1.95s] <warning>Package swiftmailer/swiftmailer is abandoned, you should avoid using it. Use symfony/mailer instead.</warning>
[20.9MiB/1.95s] <warning>Package symfony/inflector is abandoned, you should avoid using it. Use EnglishInflector from the String component instead.</warning>
[20.9MiB/1.95s] <warning>Package symfony/swiftmailer-bundle is abandoned, you should avoid using it. Use symfony/mailer instead.</warning>
[20.9MiB/1.95s] <warning>Package twig/extensions is abandoned, you should avoid using it. No replacement was suggested.</warning>
[20.9MiB/1.95s] <warning>Package fzaninotto/faker is abandoned, you should avoid using it. No replacement was suggested.</warning>
[20.9MiB/1.95s] Generating optimized autoload files
[38.0MiB/4.11s] <warning>Class Eccube\Entity\Customer located in ./app/proxy/entity/src/Eccube/Entity/Customer.php does not comply with psr-4 autoloading standard. Skipping.</warning>
[38.0MiB/4.12s] <warning>Class Eccube\Entity\Order located in ./app/proxy/entity/src/Eccube/Entity/Order.php does not comply with psr-4 autoloading standard. Skipping.</warning>
[38.0MiB/4.12s] <warning>Class Eccube\Entity\ProductClass located in ./app/proxy/entity/src/Eccube/Entity/ProductClass.php does not comply with psr-4 autoloading standard. Skipping.</warning>
[26.1MiB/4.69s] 103 packages you are using are looking for funding.
[26.1MiB/4.69s] Use the `composer fund` command to find out more!
[26.1MiB/4.69s] Memory usage: 26.08MiB (peak: 60.05MiB), time: 4.69s


正常の場合もwarningは出ます。
エラーが発生している場合は、error等のメッセージがでます。

正しくインストール出来ていない場合は、該当プラグインをアンインストール等を行い再度インストールをお試しください。
また、該当プラグインは有料プラグインの様ですのでプラグイン提供元に確認する事をオススメ致します。


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

you01haya
投稿日時: 2023/1/9 16:00
対応状況: 保留
新米
登録日: 2022/10/12
居住地:
投稿: 5
Re: 「簡単ブログ Pro for EC-CUBE4 」のプラグインがインストールできない
mcontact様

返信およびお礼、遅くなってしまい申し訳ございません。
ご協力ならびにアドバイスいただき、ありがとうございました。

なんとかインストールすることはできました。
(有効化するとシステムエラーが生じてしまいますが...)

コンソールで『composer -v』 のコマンドを入力すると
下記メッセージが表示されましたので、『y』を入力することで、
"ec-cube/plugin-installer"との依存関係の整合ができたのでは、と推測しています。

ec-cube/plugin-installer contains a Composer plugin which is currently not in your allow-plugins config. See https://getcomposer.org/allow-plugins
Do you trust "ec-cube/plugin-installer" to execute code and wish to enable it now?
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン



統計情報

総メンバー数は78,122名です
総投稿数は106,053件です

投稿数ランキング

1
seasoft
7333
2
468
3217
3
AMUAMU
2712
4
nanasess
2280
5
umebius
2085
6
yuh
1745
7
red
1558
8
h_tanaka
1301
9
tsuji
957
10
fukap
907
11
shutta
835
12
tao_s
794
13 ramrun 789
14 karin 689
15 sumida 641
16
homan
633
17 DELIGHT 572
18
patapata
502
19
flealog
485
20 tonton 437


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.