バージョン選択

フォーラム

メニュー

オンライン状況

57 人のユーザが現在オンラインです。 (50 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 57
もっと...

サイト内検索

質問 > その他 > プラグインがインストールできない

その他

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
yu86
投稿日時: 2024/3/28 13:01
対応状況: −−−
新米
登録日: 2024/3/28
居住地:
投稿: 10
プラグインがインストールできない
▼テンプレート
[EC-CUBE] 4.2.0 さくらサーバーのクイックインストール
[レンタルサーバ] さくらのレンタルサーバー
[OS] Windows11
[PHP] 8.3.2
[データベース] DB名:masatomiplan_management、MySQL5.7
[WEBサーバ] WEBサーバ名:/home/masatomiplan/www
[ブラウザ] GoogleCrome123.0.6312.59
[導入プラグインの有無] なし(初期プラグインも削除済み)
[カスタマイズの有無] 管理項目からindex.twigを修正
            商品詳細の商品情報を修正
            問い合わせフォームの修正

[現象] 管理画面のオーナーズストア→プラグイン→プラグイン一覧画面で、公式サイトより入手したSBペイメントサービス決済プラグイン(コード:SoftbankPayment42)をインストールボタンから進みインストールしようとすると、インストール確認画面に「システムエラーが発生しました」と表示され、ログを確認すると以下のようになっていました。

[ログ]
**************** SoftbankPayment42 ****************
<warning>A script named compile would override a Composer command and has been skipped</warning>
<warning>A script named auto-scripts would override a Composer command and has been skipped</warning>
<warning>A script named installer-scripts would override a Composer command and has been skipped</warning>
[6.0MiB/0.95s] Using version ^4.2 for ec-cube/softbankpayment42
[6.0MiB/0.95s] ./composer.json has been updated
[7.3MiB/1.08s] Running composer update ec-cube/softbankpayment42 --with-dependencies
[10.2MiB/1.11s] Loading composer repositories with package information
[11.1MiB/2.06s] <warning>Dependency ec-cube/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.</warning>
[11.3MiB/2.11s] Updating dependencies
[12.9MiB/2.15s] Your requirements could not be resolved to an installable set of packages.
[12.9MiB/2.15s]
Problem 1
- laminas/laminas-code 4.6.0 requires php >=7.4, <8.2 -> your php version (8.3.2; overridden via config.platform, same as actual) does not satisfy that requirement.
- symfony/proxy-manager-bridge v5.4.6 requires friendsofphp/proxy-manager-lts ^1.0.2 -> satisfiable by friendsofphp/proxy-manager-lts[v1.0.12].
- friendsofphp/proxy-manager-lts v1.0.12 requires laminas/laminas-code ~3.4.1|^4.0 -> satisfiable by laminas/laminas-code[4.6.0].
- symfony/proxy-manager-bridge is locked to version v5.4.6 and an update of this package was not requested.

[12.9MiB/2.15s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
[11.8MiB/2.15s] You can also try re-running composer require with an explicit version constraint, e.g. "composer require ec-cube/SoftbankPayment42:*" to figure out if any version is installable, or "composer require ec-cube/SoftbankPayment42:^2.1" if you know which you need.
[11.8MiB/2.15s]
Installation failed, reverting ./composer.json and ./composer.lock to their original content.
[11.8MiB/2.15s] Memory usage: 11.76MiB (peak: 13.27MiB), time: 2.15s

{"success":false,"log":"\u003Cwarning\u003EA script named compile would override a Composer command and has been skipped\u003C\/warning\u003E\n\u003Cwarning\u003EA script named auto-scripts would override a Composer command and has been skipped\u003C\/warning\u003E\n\u003Cwarning\u003EA script named installer-scripts would override a Composer command and has been skipped\u003C\/warning\u003E\n[6.0MiB\/0.95s] Using version ^4.2 for ec-cube\/softbankpayment42\n[6.0MiB\/0.95s] .\/composer.json has been updated\n[7.3MiB\/1.08s] Running composer update ec-cube\/softbankpayment42 --with-dependencies\n[10.2MiB\/1.11s] Loading composer repositories with package information\n[11.1MiB\/2.06s] \u003Cwarning\u003EDependency ec-cube\/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.\u003C\/warning\u003E\n[11.3MiB\/2.11s] Updating dependencies\n[12.9MiB\/2.15s] Your requirements could not be resolved to an installable set of packages.\n[12.9MiB\/2.15s] \n Problem 1\n - laminas\/laminas-code 4.6.0 requires php \u003E=7.4, \u003C8.2 -\u003E your php version (8.3.2; overridden via config.platform, same as actual) does not satisfy that requirement.\n - symfony\/proxy-manager-bridge v5.4.6 requires friendsofphp\/proxy-manager-lts ^1.0.2 -\u003E satisfiable by friendsofphp\/proxy-manager-lts[v1.0.12].\n - friendsofphp\/proxy-manager-lts v1.0.12 requires laminas\/laminas-code ~3.4.1|^4.0 -\u003E satisfiable by laminas\/laminas-code[4.6.0].\n - symfony\/proxy-manager-bridge is locked to version v5.4.6 and an update of this package was not requested.\n\n[12.9MiB\/2.15s] \u003Cwarning\u003ERunning update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.\u003C\/warning\u003E\n[11.8MiB\/2.15s] You can also try re-running composer require with an explicit version constraint, e.g. \u0022composer require ec-cube\/SoftbankPayment42:*\u0022 to figure out if any version is installable, or \u0022composer require ec-cube\/SoftbankPayment42:^2.1\u0022 if you know which you need.\n[11.8MiB\/2.15s] \nInstallation failed, reverting .\/composer.json and .\/composer.lock to their original content.\n[11.8MiB\/2.15s] Memory usage: 11.76MiB (peak: 13.27MiB), time: 2.15s\n"}

[行った対応]
・WEB APIプラグインの削除

お忙しいところ恐れ入りますが、ご回答いただけると幸いです。
何卒よろしくお願い申し上げます。
tattsu
投稿日時: 2024/3/28 13:13
対応状況: −−−
長老
登録日: 2023/12/23
居住地:
投稿: 207
Re: プラグインがインストールできない
phpのバージョンをEC-CUBE4.2のシステム要件
を満たすバージョンに変更してみてください。

https://doc4.ec-cube.net/quickstart/requirement

さくらのレンタルサーバーのコントロールパネルで変更できると思います。


----------------
-------------------
EC-CUBEカスタマイズ・バージョンアップ・不具合修正 
気軽にご相談ください。ゴールドランクパートナー。

yu86
投稿日時: 2024/3/28 16:37
対応状況: −−−
新米
登録日: 2024/3/28
居住地:
投稿: 10
Re: プラグインがインストールできない
ご回答いただきありがとうございます。

PHPのバージョンを変更して試してみましたがまた新しいエラーが発生しました。
このエラーは以前別のスレッドで似たようなものを見たことがあったので下のサイトを参考にsodiumをインストールしてみましたが、エラーが発生しました。

https://www.kcapps.net/%E3%83%AC%E3%83%B3%E3%82%BF%E3%83%AB%E3%82%B5%E3%83%BC%E3%83%90%E3%83%BC/%E3%81%95%E3%81%8F%E3%82%89%E3%82%A4%E3%83%B3%E3%82%BF%E3%83%BC%E3%83%8D%E3%83%83%E3%83%88%E3%81%AE%E3%83%AC%E3%83%B3%E3%82%BF%E3%83%AB%E3%82%B5%E3%83%BC%E3%83%90%E3%83%BC%E3%81%ABsodium%E6%8B%A1/

インストールしたフォルダは以下となります。

さくらのサーバー
|
|-EC-CUBEのフォルダ
|
|-sodliumをインストールしたフォルダ(上記サイトのworkspace)

環境につきましては最初の投稿と同じです。

ここから先がインストール確認のログ確認で出力したエラーです。

**************** SoftbankPayment42 ****************
<warning>A script named compile would override a Composer command and has been skipped</warning>
<warning>A script named auto-scripts would override a Composer command and has been skipped</warning>
<warning>A script named installer-scripts would override a Composer command and has been skipped</warning>
[6.7MiB/1.02s] Using version ^4.2 for ec-cube/softbankpayment42
[6.7MiB/1.02s] ./composer.json has been updated
[8.2MiB/1.14s] Running composer update ec-cube/softbankpayment42 --with-dependencies
[11.2MiB/1.17s] Loading composer repositories with package information
[12.1MiB/2.21s] <warning>Dependency ec-cube/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.</warning>
[12.4MiB/2.25s] Updating dependencies
[14.2MiB/2.30s] Your requirements could not be resolved to an installable set of packages.
[14.2MiB/2.30s]
Problem 1
- lcobucci/jwt 4.2.1 requires ext-sodium * -> it is missing from your system. Install or enable PHP's sodium extension.
- league/oauth2-server-bundle v0.3.0 requires league/oauth2-server ^8.3 -> satisfiable by league/oauth2-server[8.3.5].
- ec-cube/api42 4.2.3 requires league/oauth2-server-bundle ^0.3 -> satisfiable by league/oauth2-server-bundle[v0.3.0].
- league/oauth2-server 8.3.5 requires lcobucci/jwt ^3.4.6 || ^4.0.4 -> satisfiable by lcobucci/jwt[4.2.1].
- ec-cube/api42 is locked to version 4.2.3 and an update of this package was not requested.

To enable extensions, verify that they are enabled in your .ini files:
- /usr/local/php/8.1/etc/php.ini
- /usr/local/php/8.1/etc/conf.d/apcu.ini
- /usr/local/php/8.1/etc/conf.d/imagick.ini
- /usr/local/php/8.1/etc/conf.d/mcrypt.ini
- /usr/local/php/8.1/etc/conf.d/opcache.ini
- /home/masatomiplan/.php.config/php.ini
You can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode.
Alternatively, you can run Composer with `--ignore-platform-req=ext-sodium` to temporarily ignore these required extensions.
[14.2MiB/2.30s] <warning>Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.</warning>
[12.8MiB/2.30s] You can also try re-running composer require with an explicit version constraint, e.g. "composer require ec-cube/SoftbankPayment42:*" to figure out if any version is installable, or "composer require ec-cube/SoftbankPayment42:^2.1" if you know which you need.
[12.8MiB/2.30s]
Installation failed, reverting ./composer.json and ./composer.lock to their original content.
[12.7MiB/2.30s] Memory usage: 12.71MiB (peak: 14.63MiB), time: 2.3s

{"success":false,"log":"\u003Cwarning\u003EA script named compile would override a Composer command and has been skipped\u003C\/warning\u003E\n\u003Cwarning\u003EA script named auto-scripts would override a Composer command and has been skipped\u003C\/warning\u003E\n\u003Cwarning\u003EA script named installer-scripts would override a Composer command and has been skipped\u003C\/warning\u003E\n[6.7MiB\/1.02s] Using version ^4.2 for ec-cube\/softbankpayment42\n[6.7MiB\/1.02s] .\/composer.json has been updated\n[8.2MiB\/1.14s] Running composer update ec-cube\/softbankpayment42 --with-dependencies\n[11.2MiB\/1.17s] Loading composer repositories with package information\n[12.1MiB\/2.21s] \u003Cwarning\u003EDependency ec-cube\/plugin-installer is also a root requirement. Package has not been listed as an update argument, so keeping locked at old version. Use --with-all-dependencies (-W) to include root dependencies.\u003C\/warning\u003E\n[12.4MiB\/2.25s] Updating dependencies\n[14.2MiB\/2.30s] Your requirements could not be resolved to an installable set of packages.\n[14.2MiB\/2.30s] \n Problem 1\n - lcobucci\/jwt 4.2.1 requires ext-sodium * -\u003E it is missing from your system. Install or enable PHP\u0027s sodium extension.\n - league\/oauth2-server-bundle v0.3.0 requires league\/oauth2-server ^8.3 -\u003E satisfiable by league\/oauth2-server[8.3.5].\n - ec-cube\/api42 4.2.3 requires league\/oauth2-server-bundle ^0.3 -\u003E satisfiable by league\/oauth2-server-bundle[v0.3.0].\n - league\/oauth2-server 8.3.5 requires lcobucci\/jwt ^3.4.6 || ^4.0.4 -\u003E satisfiable by lcobucci\/jwt[4.2.1].\n - ec-cube\/api42 is locked to version 4.2.3 and an update of this package was not requested.\n\nTo enable extensions, verify that they are enabled in your .ini files:\n - \/usr\/local\/php\/8.1\/etc\/php.ini\n - \/usr\/local\/php\/8.1\/etc\/conf.d\/apcu.ini\n - \/usr\/local\/php\/8.1\/etc\/conf.d\/imagick.ini\n - \/usr\/local\/php\/8.1\/etc\/conf.d\/mcrypt.ini\n - \/usr\/local\/php\/8.1\/etc\/conf.d\/opcache.ini\n - \/home\/masatomiplan\/.php.config\/php.ini\nYou can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode.\nAlternatively, you can run Composer with `--ignore-platform-req=ext-sodium` to temporarily ignore these required extensions.\n[14.2MiB\/2.30s] \u003Cwarning\u003ERunning update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.\u003C\/warning\u003E\n[12.8MiB\/2.30s] You can also try re-running composer require with an explicit version constraint, e.g. \u0022composer require ec-cube\/SoftbankPayment42:*\u0022 to figure out if any version is installable, or \u0022composer require ec-cube\/SoftbankPayment42:^2.1\u0022 if you know which you need.\n[12.8MiB\/2.30s] \nInstallation failed, reverting .\/composer.json and .\/composer.lock to their original content.\n[12.7MiB\/2.30s] Memory usage: 12.71MiB (peak: 14.63MiB), time: 2.3s\n"}

皆様何とぞお力添えいただければ幸いです。
mcontact
投稿日時: 2024/3/28 16:49
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1285
Re: プラグインがインストールできない
> - lcobucci/jwt 4.2.1 requires ext-sodium * -> it is missing from your system. Install or enable PHP's sodium extension.

インストール時のログにて、sodiumの拡張がインストールされていないと出ています。
sodiumのインストールをしたとの事ですが、Apacheの再起動は行いましたか?
sodiumを有効にするには、Apacheを再起動しない限りはPHPに反映されません。


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

tattsu
投稿日時: 2024/3/28 18:09
対応状況: −−−
長老
登録日: 2023/12/23
居住地:
投稿: 207
Re: プラグインがインストールできない
レンタルサーバーなのでApacheの再起動はできないと思いますが
ここに書かれている通りにやってみてはいかがでしょうか。

引用:
To enable extensions, verify that they are enabled in your .ini files:
- /usr/local/php/8.1/etc/php.ini
- /usr/local/php/8.1/etc/conf.d/apcu.ini
- /usr/local/php/8.1/etc/conf.d/imagick.ini
- /usr/local/php/8.1/etc/conf.d/mcrypt.ini
- /usr/local/php/8.1/etc/conf.d/opcache.ini
- /home/masatomiplan/.php.config/php.ini


----------------
-------------------
EC-CUBEカスタマイズ・バージョンアップ・不具合修正 
気軽にご相談ください。ゴールドランクパートナー。

yu86
投稿日時: 2024/3/29 11:18
対応状況: 解決済
新米
登録日: 2024/3/28
居住地:
投稿: 10
Re: プラグインがインストールできない
こちらの通りにやってみるとインストールができました!
皆様お忙しいところ誠にありがとうございました。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は88,712名です
総投稿数は109,949件です

投稿数ランキング

1
seasoft
7367
2
468
3217
3
AMUAMU
2712
4
nanasess
2313
5
umebius
2085
6
yuh
1819
7
h_tanaka
1638
8
red
1570
9
mcontact
1285
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.