バージョン選択

フォーラム

メニュー

オンライン状況

75 人のユーザが現在オンラインです。 (61 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 75
もっと...

サイト内検索

質問 > 管理機能 > 有料プラグインを再ダウンロードしたい

管理機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
mcontact
投稿日時: 2024/4/17 12:06
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1318
Re: 有料プラグインを再ダウンロードしたい
> また、バージョンが対応していないのか、
> MySQL自体が対応していないのか、お分かりでしょうか?

プラグイン自体がMySQLに対応しているかどうかはプラグインの提供元ではありませんし、有料プラグインでソースコードも公開されていないのでわかりません。
EC-CUBE本体自体は、MySQLであれば5.5~5.7に対応しています。
EC-CUBEのシステム要件は下記の公式ドキュメントに記載されていますので確認してください。
https://doc4.ec-cube.net/quickstart/requirement


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

tattsu
投稿日時: 2024/4/17 12:12
対応状況: −−−
長老
登録日: 2023/12/23
居住地:
投稿: 233
Re: 有料プラグインを再ダウンロードしたい
引用:
MySQL自体が対応していない、ということはよくあることなのでしょうか?
それとも、バージョンが対応していないということでしょうか?
これまで様々なプラグインを利用してきましたが、今回は初めてのケースです。


このエラーはプラグインの実装方法の問題だと思われますね。
(MySQLやバージョンが対応していないというよりも、実装の問題です。あとおそらくポスグレでも同じエラーになると思います)

bitというライブラリで定義されていないタイプを使用しているというエラーです。

エラー内容からは一概にこのプラグインが直接原因だとは言い切れないですが、今まで正常に動いていたのであればおそらくそうかと思います。

Customizeディレクトリなどで定義を追加することはできるので定義を追加すれば一応回避は可能だと思いますが、
プラグインの意図通りうごく保証はないので、使用されたいのであれば開発元に対応してもらうのが良いかと思います。


----------------
-------------------
EC-CUBEカスタマイズ・バージョンアップ・不具合修正 
気軽にご相談ください。ゴールドランクパートナー。

PRIA
投稿日時: 2024/4/18 9:43
対応状況: −−−
常連
登録日: 2020/8/24
居住地:
投稿: 34
Re: 有料プラグインを再ダウンロードしたい
tattsu様

的確なご説明、感謝いたします。
開発元に何度ご連絡しても音信不通でして
有料プラグインだというのに、なんとも無責任な開発者だなと思います。

bitというTypeを検索しても出てこないのですが、このプラグインが独自に定義している型なのでしょうか。
それでエラーが出ているのなら実装に問題があると思わざるを得ません。

>Customizeディレクトリなどで定義を追加することはできるので定義を追加すれば一応回避は可能
この線で調べ、対応してみます。
詳しい情報をくださり、ありがとうございました。
mcontact
投稿日時: 2024/4/18 10:33
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1318
Re: 有料プラグインを再ダウンロードしたい
基本的には、プラグイン提供元からの連絡のみですがEC-CUBE社へ連絡して相談してみては如何でしょうか。
https://support.ec-cube.net/hc/ja/articles/360038545832-%E8%B3%BC%E5%85%A5%E3%81%97%E3%81%9F%E3%83%97%E3%83%A9%E3%82%B0%E3%82%A4%E3%83%B3%E3%82%92%E8%BF%94%E5%93%81%E3%81%97%E3%81%9F%E3%81%84


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

tattsu
投稿日時: 2024/4/18 10:37
対応状況: −−−
長老
登録日: 2023/12/23
居住地:
投稿: 233
Re: 有料プラグインを再ダウンロードしたい

>bitというTypeを検索しても出てこないのですが、このプラグインが独自に定義している型なのでしょうか。

見てないので何とも言えないのですが、プラグインには書かれておらずプラグインが使用しているライブラリが使用しているとか、そういったケースもあります。
(また、本当に直接そのプラグインが原因かどうかを断言することも難しいです)


----------------
-------------------
EC-CUBEカスタマイズ・バージョンアップ・不具合修正 
気軽にご相談ください。ゴールドランクパートナー。

« 1 (2)
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は89,586名です
総投稿数は110,139件です

投稿数ランキング

1
seasoft
7367
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1656
8
red
1570
9
mcontact
1318
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.