バージョン選択

フォーラム

メニュー

オンライン状況

68 人のユーザが現在オンラインです。 (55 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 67
tattsu もっと...

サイト内検索

質問 > 管理機能 > トップページがインデックス登録されません。

管理機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
nobuHiro
投稿日時: 2022/5/10 17:45
対応状況: 開発中
新米
登録日: 2022/5/10
居住地:
投稿: 3
トップページがインデックス登録されません。
[EC-CUBE] 4.1.2
[レンタルサーバ] Xserver
[OS] Linux
[PHP] 7.4.25
[データベース] MySQL 10.5.13
[WEBサーバ] Apache
[ブラウザ] chrome
[導入プラグインの有無] Site kitプラグイン、EC-CUBEアップデートプラグイン(EccubeUpdater411to412)

[現象]
Googleサーチコンソールからトップページ(/)やサイト概要(/about)などのインデックス登録リクエストしていますが、「いいえ、'X-Robots-Tag' http ヘッダーで 'noindex' が検出されました」となり登録できません。
ページ管理のrobotは記載なし(データベース上ではnull)となっているのですが、他に対応すべきところがあるのでしょうか?
あるいは、放っておけば登録されるのでしょうか?

尚、サイトマップは正常に処理されています。(ドメインの後ろにsitemap.xmlと書いて送信しただけで、プラグインなどでサイトマップの作成はしていません。)

他に気になる点は、Googleのsite kitプラグインでダッシュボードを開くと「システムエラー」となり開けません。(再インストールしてみても同じ)

よろしくお願いいたします。
nobuHiro
投稿日時: 2022/5/11 9:44
対応状況: 解決済
新米
登録日: 2022/5/10
居住地:
投稿: 3
Re: トップページがインデックス登録されません。
自己解決しました。

.envファイルの
 APP_ENV=prod
 APP_DEBUG=0
とすべきところが、
 APP_ENV=prod
 APP_DEBUG=1(デバッグモードが有効)
になっていたのが原因のようでした。

Google site kitも無事に見られるようになりました。

本番環境に移行する際には、色々な意味でデバッグモードの解除を忘れずに・・・(自分への戒め)
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は90,091名です
総投稿数は110,312件です

投稿数ランキング

1
seasoft
7369
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1681
8
red
1571
9
mcontact
1350
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.