バージョン選択

フォーラム

メニュー

オンライン状況

27 人のユーザが現在オンラインです。 (16 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 27
もっと...

サイト内検索

プラグイン > バグ報告・利用に関する質問 > EC-CUBEアップデートプラグイン EccubeUpdater410to411 でエラーが発生します。

バグ報告・利用に関する質問

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
mmm401
投稿日時: 2023/4/28 11:59
対応状況: −−−
新米
登録日: 2023/4/28
居住地:
投稿: 6
EC-CUBEアップデートプラグイン EccubeUpdater410to411 でエラーが発生します。
▼テンプレート
[EC-CUBE] 4.1.0
[レンタルサーバ]
[OS] Linux
[PHP] 7.4.33
[データベース]
[WEBサーバ]
[ブラウザ] Chrome 112
[導入プラグインの有無]
[カスタマイズの有無]
[現象]
EC-CUBE4.0.5からアップデートプラグインを利用して4.1.0までアップデートしています。
同じ手順で、EC-CUBE 4.1.0から、4.1.1へアップデートしたく、アップデートプラグイン EccubeUpdater410to411 でのアップデートをしたところ、エラーが発生して進めません。プラグインのインストールは成功しています。

プラグイン一覧より、EccubeUpdater410to411の歯車マーク(設定)クリック→プラグイン対応状況確認へボタンを押すと、500エラーが発生します。

エラー内容としては、以下の通りです。
ーーーーーーーー
Eccube\Exception\
PluginApiException
in src/Eccube/Service/PluginApiService.php (line 322)
ーーーーーーーー

4.1.0へのアップデート段階で、APIプラグイン自動的にインストールされていますが、有効化はしていません。

解消方法を教えていただきたいです。
mcontact
投稿日時: 2023/4/28 13:16
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1312
Re: EC-CUBEアップデートプラグイン EccubeUpdater410to411 でエラーが発生します。
EC-CUBEのログは確認できますか?
どのようなエラーが出ますでしょうか?
var/log/prod/site-yyyy-mm-dd.log に「システムエラーが発生しました」といった行がありましたらご提示ください。


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

mmm401
投稿日時: 2023/4/28 14:42
対応状況: −−−
新米
登録日: 2023/4/28
居住地:
投稿: 6
Re: EC-CUBEアップデートプラグイン EccubeUpdater410to411 でエラーが発生します。
ご返信ありがとうございます。

その後、内部エラーを確認したところ、4.1.0未対応のプラグインがインストールされていることが原因と判明しましたので、対象プラグインを削除いたしました。

削除方法としては、
・管理画面プラグイン一覧より削除
・キャッシュクリア
通常、こちらで削除されるはずですが、消えなかったため、

https://xoops.ec-cube.net/modules/newbb/viewtopic.php?topic_id=26643&forum=16

こちらを参考に
・dtb_pluginから該当プラグインレコードの削除
・app/Plugin/から該当プラグインフォルダの削除
を実施いたしました。

非対応プラグイン削除後、500エラーの発生は解消しましたが、「プラグインの対応状況の確認へ」ボタンを押すと、eccube_updater_410_to_411/config でページロードが長時間続き、タイムアウト(ERR_TIMED_OUT)に変わりました。

アップデート確認はテスト環境で実施しているため、ENVはdevとしていますが、
var/log/dev/site-yyyy-mm-dd.logには、エラーログは出ていません。
mcontact
投稿日時: 2023/4/28 16:39
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1312
Re: EC-CUBEアップデートプラグイン EccubeUpdater410to411 でエラーが発生します。
https://www.ec-cube.net/products/detail.php?product_id=2334

プラグイン提供ページに記載されている
> アップデートを実行する前に、以下の設定をご確認ください。
> ・xdebugが有効になっている→xdebugを無効にする
> ・memory_limitが128M→memory_limitを512Mに設定
> ・max_execution_timeが30→max_execution_timeを180に設定

を設定しているのでしょうか?


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

mmm401
投稿日時: 2023/5/10 12:17
対応状況: −−−
新米
登録日: 2023/4/28
居住地:
投稿: 6
Re: EC-CUBEアップデートプラグイン EccubeUpdater410to411 でエラーが発生します。
ご返信ありがとうございます。

xdebug、memory_limit、max_execution_timeはプラグイン提供ページ記載の設定になっています。

SSH接続し、bin/console listを実行したところ、composerでのエラーが発覚しました。
自分の環境ではなぜかcarbonが存在していないことが原因だったようで、
bin/console eccube:composer:require nesbot/carbon
を実施し、composerエラーを解消したところ、タイムアウトは解消しています。

その後、
・4.1.1非対応プラグインの削除(dtb_pluginのデータを含む)
・./gulp/〜への書き込み権限付与
を実施したところ、アップデートが進み、差分ファイルの書き換えまで進みましたが、今度は別のエラーが発生しました。

Warning: include(/var/www/html/vendor/composer/../friendsofphp/proxy-manager-lts/src/ProxyManager/Configuration.php): failed to open stream: No such file or directory


friendsofphp/proxy-manager-ltsが存在しないエラーのようでしたので、carbon同様に

bin/console eccube:composer:require friendsofphp/proxy-manager-lts

を実行してみましたが、同じエラーが出てrequireできません。
また、composer.pharからのrequireも試しましたが、こちらは以下エラーとなります。

php composer.phar install friendsofphp/proxy-manager-lts

PHP Fatal error: Class Symfony\Flex\Configurator\CopyFromPackageConfigurator contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (Symfony\Flex\Configurator\AbstractConfigurator::update) in /var/www/html/vendor/symfony/flex/src/Configurator/CopyFromPackageConfigurator.php on line 131

Fatal error: Class Symfony\Flex\Configurator\CopyFromPackageConfigurator contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (Symfony\Flex\Configurator\AbstractConfigurator::update) in /var/www/html/vendor/symfony/flex/src/Configurator/CopyFromPackageConfigurator.php on line 131
mmm401
投稿日時: 2023/5/10 12:51
対応状況: −−−
新米
登録日: 2023/4/28
居住地:
投稿: 6
Re: EC-CUBEアップデートプラグイン EccubeUpdater410to411 でエラーが発生します。
自己レスです。

vendor配下に問題があると判断し、一旦vendorを削除後、

php composer.phar install
php composer.phar dump-autoload
bin/console eccube:composer:update
php composer.phar dump-autoload

の順番に実行したところ、エラーメッセージが php-http/message-factory 
をrequireする必要があるメッセージに変化しました(すみません、具体的なメッセージ内容コピーし忘れました)ので、指定された通り、

php composer.phar require php-http/message-factory
を実行したところバージョンアップが完了いたしました。

mmm401
投稿日時: 2023/5/10 15:27
対応状況: 解決済
新米
登録日: 2023/4/28
居住地:
投稿: 6
Re: EC-CUBEアップデートプラグイン EccubeUpdater410to411 でエラーが発生します。
解決済みとさせていただきます。
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は89,539名です
総投稿数は110,117件です

投稿数ランキング

1
seasoft
7367
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1656
8
red
1570
9
mcontact
1312
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.