バージョン選択

フォーラム

メニュー

オンライン状況

106 人のユーザが現在オンラインです。 (95 人のユーザが フォーラム を参照しています。)
登録ユーザ: 1
ゲスト: 105
liarose304 もっと...

サイト内検索

質問 > フロント機能 > サーバー移行500エラー

フロント機能

新規スレッドを追加する

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
mrb56
投稿日時: 2024/4/2 6:26
対応状況: −−−
常連
登録日: 2016/2/3
居住地:
投稿: 33
サーバー移行500エラー
▼テンプレート
[EC-CUBE] EC-CUBE4.0
[レンタルサーバ] さくらサーバー
[データベース] SQLite

さくらサーバーからさくらサーバーへ移行をするため、全てのファイルを移しました。ドメインも同じでフォルダを設置する階層も同じです。データベースもSQLiteを使っていたため環境変数も殆ど変更の必要がないかと思います。
ですが、500エラーとなってしまい下記のようなエラーが出てしまいます。PHPのバージョンに関連したエラーでしょうか?
解決策が知りたいです。
よろしくお願い致します。


▼エラー内容

コンパイル エラー: Doctrine\DBAL\Driver\PDOConnection::query() の宣言は PDO::query(string $query, ?int $fetchMode = null,mixed ...$fetchModeArgs): PDOStatement|false と互換性がある必要があります
tattsu
投稿日時: 2024/4/2 7:40
対応状況: −−−
長老
登録日: 2023/12/23
居住地:
投稿: 275
Re: サーバー移行500エラー
PHPのバージョンに関連したエラーだと思いますので
PHPバージョン情報を共有お願いします


----------------
-------------------
EC-CUBEカスタマイズ・バージョンアップ・不具合修正 
気軽にご相談ください。ゴールドランクパートナー。

mrb56
投稿日時: 2024/4/2 8:30
対応状況: −−−
常連
登録日: 2016/2/3
居住地:
投稿: 33
Re: サーバー移行500エラー
ありがとうございます。
すみません。PHPバーション情報が分かるファイルはどこにありますか?
tattsu
投稿日時: 2024/4/2 8:31
対応状況: −−−
長老
登録日: 2023/12/23
居住地:
投稿: 275
Re: サーバー移行500エラー
こちらが参考になります。

https://help.sakura.ad.jp/rs/2241/


----------------
-------------------
EC-CUBEカスタマイズ・バージョンアップ・不具合修正 
気軽にご相談ください。ゴールドランクパートナー。

mrb56
投稿日時: 2024/4/2 10:54
対応状況: −−−
常連
登録日: 2016/2/3
居住地:
投稿: 33
Re: サーバー移行500エラー
ありがとうございます。
移行先のさくらサーバーはPHPのバージョン8.2.15 (モジュールモード)で設定されていました。そして移行したいECキューブのPHPバージョンですが、composer.json(合っていますか?)に記載されている下記だとすると7.1.3でした。これだと移行は厳しいでしょうか?それともECキューブ側で修正は可能でしょうか?


▼移行したいECキューブのcomposer.jsonに記載内容

"require": {
"php": "^7.1.3"
}


mcontact
投稿日時: 2024/4/2 11:10
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1401
Re: サーバー移行500エラー
EC-CUBE4.0系であればシステム要件として利用できるのは、PHP7.3~PHP7.4です、
※一部バージョンにより、PHP7.1~になります。
PHP8系はシステム要件として対応していませんので、対応するPHPのミドルウェアにしましょう。

詳しいシステム要件は下記に記載されています。
https://doc4.ec-cube.net/quickstart/requirement


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

tattsu
投稿日時: 2024/4/2 11:19
対応状況: −−−
長老
登録日: 2023/12/23
居住地:
投稿: 275
Re: サーバー移行500エラー
引用:
移行先のさくらサーバーはPHPのバージョン8.2.15 (モジュールモード)で設定されていました。そして移行したいECキューブのPHPバージョンですが、composer.json(合っていますか?)に記載されている下記だとすると7.1.3でした。これだと移行は厳しいでしょうか?それともECキューブ側で修正は可能でしょうか?


移行先で設定可能なPHPのバージョンによりますので、何とも言えないです。8.2.15しか使えないということでしょうか?

EC-CUBE4.0はphp7.1に対応していますが、phpのバージョンを変更したいということですか?


----------------
-------------------
EC-CUBEカスタマイズ・バージョンアップ・不具合修正 
気軽にご相談ください。ゴールドランクパートナー。

mrb56
投稿日時: 2024/4/2 11:20
対応状況: −−−
常連
登録日: 2016/2/3
居住地:
投稿: 33
Re: サーバー移行500エラー
ありがとうございます。
システム要件として合っていないということですね。

>対応するPHPのミドルウェアにしましょう。

すみませんが、詳しくないため具体的にどのようなことをするのか教えていただけますでしょうか。
mcontact
投稿日時: 2024/4/2 11:30
対応状況: −−−
登録日: 2022/1/22
居住地:
投稿: 1401
Re: サーバー移行500エラー
サーバの事ですので、御社のエンジニア、またはご利用されているサーバ会社に確認頂くか、またはEC-CUBEインテグレートパートナーに相談されることをオススメ致します。
https://www.ec-cube.net/integrate/partner/


----------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
EC-CUBEインテグレートパートナー【ゴールド】ランク
M&I Works
URL: https://miworks.biz/
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

mrb56
投稿日時: 2024/4/2 11:37
対応状況: −−−
常連
登録日: 2016/2/3
居住地:
投稿: 33
Re: サーバー移行500エラー
>移行先で設定可能なPHPのバージョンによりますので、何とも言えないです。8.2.15しか使えないということでしょうか?


移行先のPHPのバージョン設定を見るとPHP8.3とPHP8.2が推奨で8.1が非推奨(2024/11月で終了)、それ以下のバージョンはサポート終了となっています。


>EC-CUBE4.0はphp7.1に対応していますが、phpのバージョンを変更したいということですか?

移行元のEC-CUBE4.0をそのまま移行先にて使えるようにしたいため、
そのエラーになってしまうECキューブ4.0を修正(PHPのバージョン変更など?←可能か分かりません)は可能か伺いました。
(1) 2 »
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ


 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は90,955名です
総投稿数は110,528件です

投稿数ランキング

1
seasoft
7369
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1704
8
red
1571
9
mcontact
1401
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.