バージョン選択

フォーラム

メニュー

オンライン状況

85 人のユーザが現在オンラインです。 (74 人のユーザが フォーラム を参照しています。)
登録ユーザ: 0
ゲスト: 85
もっと...

サイト内検索

質問 > 管理機能 > 商品並び替えプラグインSortProduct42Plus 4.2.2へのバージョンアップでエラー4.2.1は問題ない

管理機能

新規スレッドを追加する

フラット表示 前のトピック | 次のトピック
投稿者 スレッド
kicks
投稿日時: 2024/1/2 22:52
対応状況: 確認中
常連
登録日: 2012/5/15
居住地:
投稿: 56
商品並び替えプラグインSortProduct42Plus 4.2.2へのバージョンアップでエラー4.2.1は問題ない
▼テンプレート
[EC-CUBE] EC-CUBEのバージョン、
4.2.3
[レンタルサーバ] Xサーバー
[OS]
Linux 5.4.0-164-generic

[PHP] 8.1.22

[ブラウザ] 全ブラウザ

[カスタマイズの有無] なし
[現象]
開発環境では4.2.1で稼働していたプラグインが、今回アップデート通知が来ていたので4.2.2にアップデートし、キャッシュクリアしたところ定番の
システムエラーが発生しました。

大変お手数ですが、サイト管理者までご連絡ください。

と出てきます。毎度3系などでも常に起こりうるたった少しのマイナーバージョンアップで都度問題が起こってしまうEC-CUBEに辟易してしまいますが、GPTの回答は

SortProductRepository.php:39

具体的な修正方法は、このファイルの 39 行目を見ることです。その行で fetchAll メソッドが呼ばれている場合、それを適切なメソッドに置き換える必要があります。

例えば、fetchAllAssociative メソッドに置き換える場合、以下のように修正できます:


// もとのコード
$results = $connection->fetchAll($query);

// 修正後のコード
$results = $connection->fetchAllAssociative($query);

一応行ってみたが改善されず・・・開発元からもアナウンスがないので、このプラグインをいれずに商品並び替えができる場合はご教授頂きたく
フラット表示 前のトピック | 次のトピック


題名 投稿者 日時
 » 商品並び替えプラグインSortProduct42Plus 4.2.2へのバージョンアップでエラー4.2.1は問題ない kicks 2024/1/2 22:52
     Re: 商品並び替えプラグインSortProduct42Plus 4.2.2へのバージョンアップでエラー4.2.1は問題ない mcontact 2024/1/3 13:33

 



ログイン


EC-CUBE公式 Amazon Payプラグイン

統計情報

総メンバー数は89,663名です
総投稿数は110,149件です

投稿数ランキング

1
seasoft
7367
2
468
3217
3
AMUAMU
2712
4
nanasess
2314
5
umebius
2085
6
yuh
1819
7
h_tanaka
1657
8
red
1570
9
mcontact
1326
10
tsuji
958
11
fukap
907
12
shutta
835
13
tao_s
799
14 ramrun 789
15 karin 689
16 sumida 641
17
homan
633
18 DELIGHT 572
19
patapata
502
20
flealog
485


ネットショップの壺

EC-CUBEインテグレートパートナー

Copyright© EC-CUBE CO.,LTD. All Rights Reserved.